Patch-Setup funktioniert nicht (immer)

Expand / Collapse
 

Patch-Setup funktioniert nicht (immer)


Problem

Werden mehrere Patch-Setups zu einem vollständigen Setup erstellt, funktioniert die Patch-Installation ab dem zweiten Patch-Setup nur noch, wenn die Basis-Installation ohne Patch aktualisiert wird, ansonsten erhält man die Fehlermeldung: "Die Installation von [ProductName] ist fehlgeschlagen: Das Updatepatch kann nicht vom Windows-Installationsdienst aktualisiert werden, da das zu aktualisierende Programm nicht vorhanden ist oder eine andere Version des Programms mit dem Patch aktualisiert wird. Überprüfen Sie, ob das zu aktualisierende Programm vorhanden ist und das richtige Updatepatch verwendet wird.".

Beispiel, wann der Fehler auftritt:

Basis-Installation + Patch 1 + Patch 2

Beispiel, wann der Fehler nicht auftritt:

Basis-Installation + Patch 2

Ursache

Werden mehrere Patch-Setups zu einem vollständigen Setup erstellt, spielt die "Product Version" eine Rolle (warum, weiß ich leider auch nicht), wenn auf dem zu installierenden Rechner eine Basis-Installation + einem vorhergehenden Patch bereits vorhanden ist und die "Product Version" des Patch-Setups unterschiedlich zu der des vollständigen Setups ist.

Lösung

Die "Product Version" (InstallAware Design-Ansicht / Application Information / Project Properties) nur beim Build eines vollständigen Setups ändern. Wird ein Patch-Setup erstellt, muss die "Product Version" identisch mit der des vollständigen Setups sein.

Anmerkung

Nicht vergessen: Immer alle Patch-Referenzen (Vollständiges Setup + alle Patch-Setups) im "Deployment / Patches"-Bereich angeben.



Rate this Article:
Tags:

Add Your Comments


Name: *
Email Address:
Web Address:
   
  
 
 
   
Verification Code:
*
 

Details
Last Modified:06.02.2008

Last Modified By: Markus Diettrich

Type: ERRDOC

Article not rated yet.

Article has been viewed 614 times.

Options